+9

Option to disable all notifications from syntevo but updates

Kanstantsin Kamkou 11 months ago • updated 2 months ago 7

Please allow paid versions to ignore all synteo messages (help us to improve ..., a new beta versions..., etc.).

+1

I think, except of updates, SmartGit only shows very few and highly relevant notifications. Seeing approximately one such notification per quarter shouldn't be too obtrusive?


Btw, if we had this option and you had this option set, you probably would not even know about UserEcho. At least that's true for the majority of our UserEcho users.

Here's a use case: we have a VM running some internal automation, and it has an older version of smartgit whose license we do not intend to update to a newer version. That version of smartgit presents us with notifications about new versions all the time, even though we never intend to upgrade it.


In this situation we would like to suppress these notifications.

+1

You already can do that in the preferences.

> Seeing approximately one such notification per quarter shouldn't be too obtrusive?

Please let me decide what is obtrusive and what isn't.


(without proofs) In my case the reason was the way smartgit saves the state. I use dropbox to share my settings among PCs. When I shutdown the PC, smartgit has no chance to store it, because the dropbox daemon already quit. So, EVERY day I see the UserEcho message*.

* I found UserEcho from your facebook/twitter because I like the product :)

Please, how to disable updates?
I really want to update SmartGit when i want, not to avoid tiresome notifies.

In the preferences, page "SmartGit updates". Note, that according to the license agreement the non-commercial license, if not updated regularly, might stop working.

@Thomas, it makes no sense. My license is expired (need to update it*) and the about dialog says: Registered (single user). I can bet you have different code-base for licensed-and non-licensed users.


p.s. nice licence trick )


* `Later you may purchase updates for a reduced price` -> goes to http page, I did a ticket for a long time ago to use https, could you check it please. meanwhile https:// works. It looks like just a content typo