0
Completed

fixup! no longer auto-squashes in interactive rebase

Nathan 8 months ago updated by Thomas Singer 8 months ago 2

I was able to open the interactive rebase dialog and have "Commit message" and "fixup! Commit message" automatically squash up until a very recent SmartGit update.

This probably broke with the "Auto-Squash" feature with identical commits.  I would rather stay with the standard git format of using "fixup! " prefix.

GOOD, I'M SATISFIED

Setting the low-level property worked.  Why did this change?  Did people not want "fixup!" messages auto-squashed?  I thought auto-squash was the default at the git command line, so maybe it should be the default for SmartGit?

Satisfaction mark by Nathan 8 months ago
Completed
Please set the low-level property git.rebaseInteractive.autoSquash to true.

There were several reasons why we didn't made the "fixup!" prefix the default. One is that when selecting a message from a previous commit it would have required an option (existed before). Instead of the limited Git default way, we thought for a GUI our 3 options in the Interactive Rebase dialog are more suitable and cover more use-cases.