+1
Completed

repository gets update only when pull. Souce tree displays already committed items even before pull.

sreenivas.pachva 4 years ago updated by Thomas Singer 2 years ago 19

repository gets update only when pull. Souce tree displays already committed items even before pull.

-2
Completed

Mark your repository as favorite. This will automatically fetch the latest changes.

Thomas, this is not a satisfying answer : you can't control how often the repo are fetched first of all. Using SmartGit everyday I almost everytime needs to do my fetch/pull manually. SourceTree is great for that, the remote changes appears almost immediately and for each commits to pull you can see every changes made.

That more sounds like SourceTree is polling the GitHub (or other servers) more often than the GitHub recommended poll time.

Certainly Colin, that was why I was talking about the impossibility to customize this behavior in SmartGit :o)


Please note though that in my company we are using an on premise instance of GitLab (and previously Gitolite). Both worked great with SourceTree.


With SmartGit, I can't understand how often it fetches the repo, but it's almost never at the right time for me... It's strange also because I see sometimes the down green arrow, but the journal view has almost never the updated content, neither the log window.

I don't pull so often : maybe once or twice a day on the 15 or so repo I'm working on. So waiting for this to be fixed, I'm primary using the GitLab activity page.

Please open another request for making the poll/fetch intervals configurable.

+1

Pierre, please make sure all related background-options are selected in the Preferences, then adjust following system properties:


https://www.syntevo.com/doc/display/SG/System+Properties#SystemProperties-Backgroundoperations

Please let us know here once you have found a configuration which is working fine for you.

All the background options were checked indeed.

Thanks very much for the documentation page, very interesting !! I've just tried, but seems poll.delay and fetch.delay are to be expressed in seconds, not minutes as stated in the page right ? (I began with a 5 value and SmartGit didn't stop updating repo...)

You are right, all values are expected to be in seconds (I think it has been minutes for older versions, but this must be a longer time ago). I've fixed the docs.

Thanks :) Can you also add in the doc the default values ? Is the poll mandatory ? I'm only interested in the fetch...

Is the fetch not directly related to poll? I didn't think it would try to do a fetch if it detected no difference with ls-remote ?

I've just saw a strange behavior. I saw the green arrow, but nothing was fetched. I add 300 value for both delay options... I quit, changed to 1 for fetch, and then restart : nothing changed after all the favs repo were updated. I waited 5 min, the fetch was finally done. I'm wondering if SmartGit does a fetch only if the last poll gives an update ? So you'll have to wait 2 poll delay before the first fetch occurs ?

I'm not sure if this delay is OK. If you want to investigate in more detail, add following line to smartgit.properties:


log4j.smartgit.repository.backgroundFetch=DEBUG

restart SmartGit, wait until the delay has occurred and check log.txt for details or -- if you can't make much sense of it -- send it to us at smartgit@syntevo.com

Hi, since yesterday the values poll 300 and fetch 120 gives pretty good results for me. I've also activate the DEBUG but not sure to understand the log content : polling seems to occurs multiple times per minute ? I'll send you this by mail as proposed.

Many thanks !

Yes, that's how it should work.

After a few hours using SmartGit with custom poll/fetch options, seems perfect to me. Many thanks !!

But it should be more visible for the user : add those options in the preferences, or at least a link to the documentation ?

Which settings are you using now?