+2
Completed

Editing of global .gitconfig file

Benny Neugebauer 3 years ago updated by Thomas Singer 2 years ago 3

In the Repository Settings in one of my projects I have configured to sign commits with my GPG key:



Now I don't want to use GPG anymore (that's why I deleted Gpg4win on my computer) but SmartGit always tries to sign my commits using "gpg2.exe".

I unchecked the "Sign all commits" option in my repository settings but if I add new repositories in SmartGit, then SmartGit still tries to sign them with GPG (even though the checkboxes are turned off).

What I am missing is a general setting within SmartGit, where I can configure GPG Signing on a global level.

+1

Removing these options currently is only possible by editing the global .gitconfig file in the %USERPROFILE% directory using a text editor.

Thanks for the info. This helped! But as suggested it would be nice to have a setting for this inside of SmartGit. :)