0
Completed

Remove dropdowns from toolbar buttons

Sergey Ivasenko 11 months ago • updated by Mikhail Chuprakov 6 months ago 18

SmartGit 17.1 Preview 13. Please, remove dropdowns from toolbar buttons. There is a menu for all commands, tollbar is only for most often used ones. Feature distracts a lot!

GOOD, I'M SATISFIED
Satisfaction mark by Sergey Ivasenko 11 months ago

I've implemented that because it offers a quicker way to access certain commands/command variants. Except of OS X (which uses a native toolbar implementation) the dropdown menus are not easily triggerable by accident (small click area), but rather intended to be shown on long click.

There is still a chance, that you can click that drop-down and this is disturbing. It makes interface unclear and this element is not standard for toolbar buttons. Previously looked much better, in my POV...

Should I remove the drop-down-click area optionally, so it only can be triggered by long click?

I think it's a good solution. Or may be out could be configured... Thank you much!

Completed
Please try the latest intermediate build 11141 (Help | Check for Latest Build) and add following line to smartgit.properties:
smartgit.toolbar.longClickPopupOnly=true

I think I liked the dropdowns. Can't say if they how helpful they are, because they're too new and I'm not used to them yet.

I agree with post creator. I tried the latest version with "smartgit.toolbar.longClickPopupOnly=true", it works very bad (0.1 sec is not a "Long Click"; I use on Windows 7). Please make settings, where you can disable dropdowns,  because it's pretty frustrating when you need only Pull and Push, but have to press 2 times instead of one. Or make "Long Click" at starting at least from 0.5 sec or so, because my clicking triggers "Long Click" almost every time, which is also very frustrating. Thanks :)

We use the system specific hover-event that usually is used to show a tooltip.

Sorry, Thomas, but it looks like you didn't even try to use this "system specific hover-event" in Windows 7, because it works horrible and for sure not as intended.


Please think about removing this feature or make settings for disabling it, because now it annoys much more then does something useful (in my case). For me for now this "feature" just ruins almost everything what was handy for me in SmartGit (and it's not only me, as you can see in this thread).


Don't make features just for making features when it can ruin accustomed experience (or make it customizable).

Hope, you'll get my feedback right, looking forward to this fix soon :)

+1

Sorry, Thomas, but it looks like you didn't even try to use this "system
specific hover-event" in Windows 7, because it works horrible and for

sure not as intended.

Of course, I did and it works fine on 99% of the machines. Maybe you have configured yours somehow non-standard?

But to make you happy I've added the VM option smartgit.toolbar.popupEnabled for 18.1 preview #12049. Set it to false and you won't see any optional popups.

Thanks! Will try it when it's available.


Btw don't you think that dropdown with one element looks silly and useless? Why there's a dropdown under "Log" button (and if there may be some situations when it is more than one, maybe it should hide dropdown in situations with one element)?


There is one popup command that represents an alternative to the current command. That way it is simpler to invoke the alternative than to have to search it in the menu.

Anyway I think you lack some understanding of how interfaces and usebility works if you think that it's handy to use such dropdowns where they are not needed. Also you should understand that people use your product for some reason, and you shouldn't ruin main features of it (for me it was fast and simple work). I recommend you to make some usaility tests on other people and ask them if they like these dropdowns. For example here I tried three times before I managed to press button without dropdown. Three times. It's not fast. It's very frustrating

+1

It looks like on your system the hover-event timeout is ultra-short. Under these non-default conditions I agree with you (by default the timeout is ~500ms). Please give the latest 18.1. preview build 12051 a try (Help | Check for Latest Build) which does not use the hover event but a plain timeout of 750ms by default.

I'm on #11174 and can't get later build. It says I have the latest.

+1

Please download the 18.1 preview portable bundle from http://www.syntevo.com/smartgit/preview and then invoke Help | Check for Latest Build.

Yes, that works, thanks! 500ms is good thought, the problem was really in system settings (not sure where else this constant used though). 750ms is too long. Myabe no need to use system settings and stick to your own constants? Anyway, now i can use SmartGit as before, thx, I appriciate that.


+1

On top I would add, that it would be nice to have the settings to enable/disable dropdown changed from UI.