+7
Completed

Support Mercurial 3.8

Eman 4 years ago updated by Thomas Singer 3 years ago 7

I always use the newest version of Mercurial and sadly SmartGit/Hg doesn't support Mercurial 3.8


is there a reason why there has to be a supported version? it should be like git where it doesn't really care what version you have installed

Are you referring to SmartGit 7.1 or 8? Yes, there is a reason why not all Hg versions are supported: there are incompatible changes in Hg, so required SmartGit extensions have to be version-specific.

+1

Yes, but it's an absolute pain when SmartSVN (on Mac) decides to update itself to 8.0, then announces that your supported Hg version (3.4) is no longer supported, and directs you to the Mercurial site, where you download 3.9, and then SmartSVN says it doesn't support 3.9 yet and you need 3.7, but the Mercurial site doesn't have 3.7 available. This is a nightmare.

I agree with you - this update process is bad. Unfortunately, from the technical side I don't know of a better way. The problem is not solely with SmartGit but also by Mercurial's website and incompatible changes of their API.

+1

How about bundling Mercurial with SmartGit then, so a new SmartGit comes with a compatible Mercurial?

I like that idea as well, sourecetree does that

Sourcetree doesn't have any issues with it, couldn't you include an option to grab a valid copy that's compatible, like the option to download a compatible version from your website that you guys compiled yourself, sourcetree does that. that's better than just telling the user "you're screwed, use a different application". or maybe just save us all the hassle and just ditch HG support if your having such a hard time supporting it.